Ahnenblattportal Forum Index
 •Portal  •Imprint  •Forum  •Search  •Profile  •Log in to check your private messages  •Log in   •Register  

 Ahnenblatt 3.0

Post new topicReply to topic
Author Message
DirkB
Administrator



Gender:
Age: 52
Joined: 20 Jan 2006
Posts: 892
Topics: 100
Location: Hamburg


germany.gif

PostPosted: 11.06.2019, 22:16    (No subject)  Reply with quoteBack to top

Die Lösung ist 2.99i Cool

Siehe hier: http://www.ahnenblattportal.de/viewtopic.php?t=7617

- Dirk

OfflineView user's profileSend private messageVisit poster's website    
Fridolin
Super Moderator



Gender:

Joined: 04 Jan 2017
Posts: 1752
Topics: 111
Location: Regio Rhein-Neckar


germany.gif

PostPosted: 11.06.2019, 22:48    (No subject)  Reply with quoteBack to top

Habs bereits probiert.

Das Lob und ein Vorschlag zur Anwendung ist hier: http://www.ahnenblattportal.de/viewtopic.php?p=57921#57921

Frido

_________________
Aktuell Win10-64 pro, Ahnenblatt 3.01 - Daten via NAS, Programm lokal

Empfehlung: Für die neue Version 3.0x die Handbücher lesen!

OfflineView user's profileSend private message    
bjew
Super Moderator



Gender:
Age: 70
Joined: 19 Jan 2006
Posts: 2954
Topics: 99
Location: südlicher gehts fast nimmer (im Allgäu)


germany.gif

PostPosted: 12.06.2019, 13:27    (No subject)  Reply with quoteBack to top

Also noch einmal:

es wurde gerade eine neue 2.99i zum Download bereitgestellt.

https://www.ahnenblatt.de/ahnenblatt-kostenlos/

Diese fügt nun bei fehlenden Ehedaten immer ein "MARR Y" (sichtbar im GEDCOM-Format) ein.

Kann quasi als Konverter verwendet werden. Mit dieser eine alte Ahnenblatt-Datei öffnen, dann wieder speichern und in AB3 geöffnet ist es dann korrekt.


Im Link oben, wird nochmal bestätigt, dass beide Versionen, 2.99x und V3.x Dateikompatibel sind.

Das ist auch für diejenigen, die sich ausschließlich für die Version 3.x interessieren wichtig und interessant!


_________________
Gruß
bjew (Bernhard) ------ manchmal etwas kurz angebunden

System: Win10 auf Laptop mit i7 --- Ahnenblatt 2.74, 2.99[h] u. V3.01

OfflineView user's profilePersonal Gallery (1)Send private message    
Guest












PostPosted: 12.06.2019, 22:36    (No subject)  Reply with quoteBack to top

Hallo,
dies ist schon mal eine tolle Verbesserung.
Mir ist jedoch aufgefallen, dass bei einigen Personen, die ein Kind aber keinen Partner / -in haben, im GEDCOM-Export auch ein MARR Y eingetragen ist. Ich hoffe das dies nicht mal später zu Problemen führt.
Werde noch forschen wann das auftritt und wann nicht.

Grüße
Volker

Online    
bjew
Super Moderator



Gender:
Age: 70
Joined: 19 Jan 2006
Posts: 2954
Topics: 99
Location: südlicher gehts fast nimmer (im Allgäu)


germany.gif

PostPosted: 12.06.2019, 22:40    (No subject)  Reply with quoteBack to top

@Volker
Danke, vllt findest noch genaueres zu dem Thema. Wird sicher verfolgt und geklärt.
Hat das an der Oberfläche, bei Listen und Tafeln irgendeine Auswirkung?

_________________
Gruß
bjew (Bernhard) ------ manchmal etwas kurz angebunden

System: Win10 auf Laptop mit i7 --- Ahnenblatt 2.74, 2.99[h] u. V3.01

OfflineView user's profilePersonal Gallery (1)Send private message    
Guest












PostPosted: 12.06.2019, 22:59    (No subject)  Reply with quoteBack to top

Hallo, hatte vergessen geht um 2.99h und 2.99i

ist jetzt etwas klarer: es scheint beim Einlesen zu passieren:
Hatte in 2.99i eine neue Datei angefangen : ein Mann und dazu ein Sohn.
Im Navigator erscheint beim Vater o-o
Dann Abspeichern als ahn und ged ( in der ged kein MARR ).
Nach dem Wiedereinlesen ist beim Vater oo und in der davon Gespeicherten ged ist ein MARR Y, auch wenn kein Partner vorhanden ist.

Ich hoffe das hilft ein wenig.

Gruß
Volker

Online    
bjew
Super Moderator



Gender:
Age: 70
Joined: 19 Jan 2006
Posts: 2954
Topics: 99
Location: südlicher gehts fast nimmer (im Allgäu)


germany.gif

PostPosted: 13.06.2019, 07:26    (No subject)  Reply with quoteBack to top

Ja, das hilft, ist ein Hinweis für Dirk, genau an diesem Eck wurde in der V2.99i geändert wink
_________________
Gruß
bjew (Bernhard) ------ manchmal etwas kurz angebunden

System: Win10 auf Laptop mit i7 --- Ahnenblatt 2.74, 2.99[h] u. V3.01

OfflineView user's profilePersonal Gallery (1)Send private message    
Fridolin
Super Moderator



Gender:

Joined: 04 Jan 2017
Posts: 1752
Topics: 111
Location: Regio Rhein-Neckar


germany.gif

PostPosted: 14.06.2019, 09:17    (No subject)  Reply with quoteBack to top

« Anonymous / Volker » wrote:
Hatte in 2.99i eine neue Datei angefangen : ein Mann und dazu ein Sohn.
Im Navigator erscheint beim Vater o-o
Dann Abspeichern als ahn und ged ( in der ged kein MARR ).
Nach dem Wiedereinlesen ist beim Vater oo und in der davon Gespeicherten ged ist ein MARR Y, auch wenn kein Partner vorhanden ist.


Wenn wir Pech haben, könnte das sogar bei reinen Geschwister-"Familien" passieren - wo es also gar keine Eltern gibt. Wäre natürlich noch absurder. Ich fühle mich da mitverantwortlich, weil ich, nachdem ich so gedrängelt habe, hier: http://www.ahnenblattportal.de/viewtopic.php?p=57897#57897 die versch. Konstellationen von Partnerschaften dargestellt und dabei zwei Fälle einfach unter den Tisch habe fallen lassen, die in GEDCOM ebenfalls noch ein FAM-Tag produzieren: Elternteil-Kind(er)-Kombi und Nur-Geschwisterkinder-Kombi. Das nächste Mal erwähne ich die Randbedingungen eher.

Frido

_________________
Aktuell Win10-64 pro, Ahnenblatt 3.01 - Daten via NAS, Programm lokal

Empfehlung: Für die neue Version 3.0x die Handbücher lesen!


Last edited by Fridolin on 14.06.2019, 13:12; edited 1 time in total

OfflineView user's profileSend private message    
ahnenarmin




Gender:

Joined: 28 Apr 2008
Posts: 248
Topics: 9
Location: D-85276 Pfaffenhofen/Ilm


germany.gif

PostPosted: 14.06.2019, 12:51    (No subject)  Reply with quoteBack to top

Konnte das Problem von Volker nachvollziehen und habe entsprechende Konstellationen auch in meinen Ahn-Dateien (mit AB 2.99i) gefunden. Gleichzeitig wurde die gleiche Konstellation (1 Elternteil mit Kind) aber manchmal auch richtig dargestellt.

Habe zu diesem Problem eine PN (mit Musterbeispielen) an Dirk geschickt. Mal schauen was rauskommt.

Gruß

Armin

OfflineView user's profileSend private message    
ahnenarmin




Gender:

Joined: 28 Apr 2008
Posts: 248
Topics: 9
Location: D-85276 Pfaffenhofen/Ilm


germany.gif

PostPosted: 16.06.2019, 13:25    (No subject)  Reply with quoteBack to top

Hallo zusammen,

nochmal zum Thema Trauungen:

AB 2.99i zeigt jetzt bei einem Elternteil (ohne Partner) und mit Kind zweierlei Verhalten:

Legt man in AB 2.99i eine neue Familie an, lediglich Vater ODER Mutter und dann eine Kind dazu, dann wird im Navigator beim Elternteil "o-o" angezeigt und bei Partner „…“.
Speichert man die ahn-Datei und öffnet sie wieder, wird statt" o-o" im Navigator das Ehesymbol "oo" angezeigt und beim Reiter Partner ebenso und das Häckchen "Verheiratet" wird gesetzt.

Öffnet man eine AHN-Datei, die bereits mit AB 2.00h oder früher erstellt wurde und dann unter AB 2.99i gespeichert wurde, so zeigt sich in den meisten Fällen das selbe Verhalten.

Ich habe aber auch Konstellationen, in denen beim Speichern unter AB 2.99i diese ungewollte Änderung nicht passiert:
Im Eingabedialog verbleibt „o-o“ und bei Reiter Partner „…“.

Ist eigenartig.
Dirk hat mir geantwortet, dass er sich das Ende nächster Woche anschauen will.

Tatsächlich gibt es ja 2 Möglichkeiten:
Der Elternteil ist nachweislich ledig und hat ein Kind und der andere Elternteil ist unbekannt.
ODER
es ist lediglich ein Elternteil bekannt (bei Beginn der Kirchenbuchaufzeichnungen ist oft nur der Vater angegeben) und keine Angaben über den Ehestatus.

Ich glaube in beiden genannten Fällen wäre die Angabe
im Eingabedialog „o-o“ und bei Reiter Partner „…“ akzeptabel. So war es meiner Meinung nach bisher unter AB 2.99 und früher.

In Tafeln und Listen wird hierüber keine Aussage getroffen, also nur ein Problem im Eingabedialog.

In AB 3.01 steht jeweils beim Fakt Heirat "nicht". Somit gibt es dies Problem nur bei AB2.99i.
Aber beide Versionen sollen ja kompatibel sein, so dass eine Korrektur erforderlich ist.

OfflineView user's profileSend private message    
Display posts from previous:      
Post new topicReply to topic


 Jump to:   




Show permissions


Board Security

Powered by Orion based on phpBB © 2001, 2002 phpBB Group
CBACK Orion Style based on FI Theme
All times are GMT + 1 Hour



[ Page generation time: 0.1134s (PHP: 82% - SQL: 18%) | SQL queries: 38 | GZIP enabled | Debug on ]