Ahnenblattportal Forum Index
 •Portal  •Imprint  •Forum  •Search  •Profile  •Log in to check your private messages  •Log in   •Register  

 (Bilddateien) AB sucht nicht auf relativem Pfad

Post new topicReply to topic
Author Message
RandolfHermann




Gender:

Joined: 01 Apr 2018
Posts: 2
Topics: 1


germany.gif

PostPosted: 06.04.2018, 10:23    (Bilddateien) AB sucht nicht auf relativem Pfad  Reply with quoteBack to top

Wenn eine Bilddatei zugeordnet wird, speichert AB zur Datei zwei Pfadangaben an:
- eine absolute (mit Laufwerksbuchstaben etc...)
- in der festinstallierten AB-Version eine relative (als relativen Pfad zur .ahn-Datei)
- in der portablen AB-Version möglichweise ungewollt eine weitere absolute (möglichweise versucht AB hier eine relativ zur .exe-Datei anzulegen)

Wenn die .ahn-Datei nun von einem anderen Pfad aus geöffnet wird, werden die Bilddateien nicht mehr auf den absoluten Pfaden gefunden. Was ja nicht problematisch sein sollte, da ja zu jedem Bild noch die relativen Pfade gespeichert sind.

Doch AB sucht die Bilder nicht auf deren relativen Pfaden. Oder bringt irgend etwas anderes durcheinander, jedenfalls werden die Bilder nicht gefunden, obwohl sie an den gespeicherten relativen Pfaden vorhanden sind.

Betrifft Versionen 2.98 (normal und portable) und die 3-er Beta.


Siehe auch:
http://www.ahnenblattportal.de/viewtopic.php?t=6696
http://www.ahnenblattportal.de/viewtopic.php?t=6940

Danke, Grüße und viel Erfolg beim debuggen.

OfflineView user's profileSend private message    
Display posts from previous:      
Post new topicReply to topic


 Jump to:   




Show permissions


Board Security

Powered by Orion based on phpBB © 2001, 2002 phpBB Group
CBACK Orion Style based on FI Theme
All times are GMT + 1 Hour



[ Page generation time: 0.0746s (PHP: 87% - SQL: 13%) | SQL queries: 23 | GZIP enabled | Debug on ]